Home > Mac administration, Mac OS X, Scripting > Removing and rebuilding a malfunctioning Recovery HD partition

Removing and rebuilding a malfunctioning Recovery HD partition

When updating to 10.7.2, there’s a Lion Recovery Update that goes along with it. This is meant to update your Recover HD recovery partition to 10.7.2 along with your Mac. However, when I tried updating, I could see from the logs that for whatever reason, my Recovery HD was staying at 10.7.1 and was not being successfully updated. As the new Find My Mac functionality in iCloud relies on Recovery HD being updated to 10.7.2, I wanted to be able to fix this problem without having to reinstall or reimage my Mac. Fortunately, thanks to the work of Clay Caviness at Google, there’s a way to rebuild your recovery partition (at least for 10.7.2) on a Mac that doesn’t have one. I did have one, but I knew how to fix that. See below the jump for the procedure.

Update – July 14, 2012 – This process creates a Recovery HD that’s running Mac OS X 10.7.2. Mac models that were introduced in 2012 (like the 2012 MacBook Pros and Airs) are not able to run 10.7.2. Joel Bruner has developed and posted a newer procedure that uses the current Lion installer from the Mac App Store to create a Recovery HD partition. If your Mac model was first introduced in 2012, I recommend using Joel’s process instead of the one below.

Note: All commands shown are single lines.

Step One: Make a full backup of your boot drive.

This is absolutely the most important step of this process. Any time you’re moving partitions around, stuff can go wrong. Making a backup beforehand can turn a later “Something went wrong” moment from a crisis into a less-bad inconvenience.

Step Two: Remove the existing Recovery HD recovery partition

1. Get the disk identifier of your recovery partition by running the following command:


diskutil list

2. Once you’ve identified the entry, then remove it by running the following command. (In this case, I’ll be using disk0s4 for the recovery partition and disk0s3 for the main boot partition.):


diskutil eraseVolume HFS+ ErasedDisk /dev/disk0s4

3. Next, merge the recovery and boot partitions together to create one partition (the MacHD identifier is to give the partition a new name; your existing boot drive name shouldn’t be changed by this process):


diskutil mergePartitions HFS+ MacHD disk0s3 disk0s4

Step Three: Rebuilding the recovery partition:

1. Download the Lion Recovery Update from http://support.apple.com/kb/DL1464

2. Run the following commands to attach the correct disk image and rebuild the recovery partition:


hdiutil attach RecoveryHDUpdate.dmg

pkgutil --expand /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update/RecoveryHDUpdate.pkg /tmp/RecoveryHDUpdate

hdiutil attach /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/RecoveryHDMeta.dmg

/tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/Scripts/Tools/dmtest ensureRecoveryPartition / /Volumes/Recovery\ HD\ Update/BaseSystem.dmg 0 0 /Volumes/Recovery\ HD\ Update/BaseSystem.chunklist

At this point, you will see a large amount of code fly by as the recovery partition is rebuilt. It should end with Creating recovery partition: finished

The next set of commands is clean-up and making the system recognize the updated recovery partition.


hdiutil eject /Volumes/Recovery\ HD\ Update
hdiutil eject /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update
sudo touch /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
sudo kextcache -f -u /

Once finished, restart your Mac and verify that you can boot to Recovery HD. To verify that your Recovery HD is now on 10.7.2, open the Terminal (available from the Utilities menu when booted from the Recovery HD partition,) and run the following command:


sw_vers

The following information should be displayed:


ProductName: Mac OS X
ProductVersion: 10.7.2
BuildVersion: 11C74

  1. October 23, 2011 at 6:39 pm

    Very cool, great work! You can also mount the Recovery HD volume and then grep for “ProductVersion” in the SystemVersion.plist file:

    diskutil mount disk0s3

    grep -A1 -i “ProductVersion” /Volumes/Recovery\ HD/com.apple.recovery.boot/SystemVersion.plist

  2. Dennis Mueller
    October 28, 2011 at 7:01 pm

    You may want to modify this line: “hdiutil eject /Volumes/Mac OS X Lion Recovery HD Update” to “hdiutil eject /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update”

    This made for a great postsetup installation of the recovery partition. Thanks

    • October 28, 2011 at 7:38 pm

      Fixed. Thanks for the catch!

  3. Dennis Mueller
    November 7, 2011 at 7:06 pm

    Here is an example of how this can be used in a postsetup for those that may be interested – deploying Lion without the recovery partition and having this script generate it.

    #!/bin/bash
    # Check for RecoveryHDUpdate and download if missing
    if [ -e “RecoveryHDUpdate.dmg” ]; then
    echo “A local copy of RecoveryHDUpdate.dmg will be used”
    else
    echo “Downloading RecoveryHDUpdate.dmg from Apple”
    curl -L -O http://support.apple.com/downloads/DL1464/en_US/RecoveryHDUpdate.dmg
    fi

    # Mount
    hdiutil attach RecoveryHDUpdate.dmg
    pkgutil –expand /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update/RecoveryHDUpdate.pkg /tmp/RecoveryHDUpdate
    hdiutil attach /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/RecoveryHDMeta.dmg
    /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/Scripts/Tools/dmtest ensureRecoveryPartition / /Volumes/Recovery\ HD\ Update/BaseSystem.dmg 0 0 /Volumes/Recovery\ HD\ Update/BaseSystem.chunklist

    # Clean-up
    hdiutil eject /Volumes/Recovery\ HD\ Update
    hdiutil eject /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update
    sleep 10
    rm RecoveryHDUpdate.dmg
    sudo touch /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
    sudo kextcache -f -u /

    • November 7, 2011 at 7:47 pm

      Thanks, Dennis! This script looks very useful for folks who need to image, but aren’t sure how to handle creating the Recovery HD partition.

    • hunsolo
      April 20, 2012 at 8:24 pm

      The script above is somewhat faulty, possibly due to formatting:
      * The 4th & 6th lines (beginning with ‘echo…’) should have similar quotes than the 3rd line (beginning with ‘if […’)
      * The 11th line (beginning with ‘pkutil…’) should have 2 dashes before expand, not a mdash.

      (I have tried to correct the lines below, but if they still are not correct, blame wordpress)

      #!/bin/bash
      # Check for RecoveryHDUpdate and download if missing
      if [ -e “RecoveryHDUpdate.dmg” ]; then
      echo “A local copy of RecoveryHDUpdate.dmg will be used”
      else
      echo “Downloading RecoveryHDUpdate.dmg from Apple”
      curl -L -O http://support.apple.com/downloads/DL1464/en_US/RecoveryHDUpdate.dmg
      fi
      # Mount
      hdiutil attach RecoveryHDUpdate.dmg
      pkgutil –expand /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update/RecoveryHDUpdate.pkg /tmp/RecoveryHDUpdate
      hdiutil attach /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/RecoveryHDMeta.dmg
      /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/Scripts/Tools/dmtest ensureRecoveryPartition / /Volumes/Recovery\ HD\ Update/BaseSystem.dmg 0 0 /Volumes/Recovery\ HD\ Update/BaseSystem.chunklist
      # Clean-up
      hdiutil eject /Volumes/Recovery\ HD\ Update
      hdiutil eject /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update
      sleep 10
      rm RecoveryHDUpdate.dmg
      sudo touch /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
      sudo kextcache -f -u /

  4. Brian Drell
    November 12, 2011 at 12:11 am

    Hmm, I have a BootCamp partition on my disk. I replaced the HD in my MB Pro after installing Lion and had restored the recovery partition to an external drive. That’s bootable, but I did it to a huge partition which was clearly a bad idea. Now I can’t restore it to a smaller partition.

    So I only have 3 primary partitions on disk — Macintosh HD, the EFI partition and the BOOTCAMP partiton. I haven’t futzed with the partition scheme since BootCamp was done.

    I’d be very hesitant to create a recovery partition with this setup, but I don’t really know what would happen. As far as you can tell, does the dmtest script resize MacintoshHD, create a new recovery partition, and then fill it?

    It’d also be nice to be able to create a new recovery partition on a USB stick, but I haven’t had any luck doing that so far.

  5. November 12, 2011 at 3:06 am

    Brian,

    Honestly, since you have the BootCamp partition in play as well, I’m not sure what would happen if you used this method to reinstall a Recovery HD partition. What I’d advise is to back up the BootCamp Windows install* and remove the Windows partition before trying to reinstall the recovery partition.

    *I have another post on how to back up a BootCamp Windows 7 install available here:

    Backing up a Windows 7 Boot Camp installation and restoring it to a smaller partition.

  6. Brian Drell
    November 15, 2011 at 12:33 am

    Great, thanks.

  7. December 4, 2011 at 8:39 pm

    Thank you so much. Nice work.

  8. slgramacho
    December 19, 2011 at 5:14 pm

    It worked like a champ for me!!!!! My Lion Recovery Partition version was 10.7, not even 10.7.1. Nothing else worked for me. I’ve tried a lot of suggestions … and I’ve lost a full working morning before finding this GREAT post.

    I suggest to change disk0s3 and disk0s4 in the script for disk0s2 (Macintosh HD) and disk0s3 (Recovery HD), because this configuration is the standard for many who do standard Lion install with only one (visible) partition for Lion.

    THANK YOU VERY MUCH!!!!!

  9. January 10, 2012 at 6:12 pm

    Great. Thanks for the catch!

  10. Toni Grabulosa
    January 22, 2012 at 6:24 pm

    Hello, I’m a starter on that… but the first line to rebuild the recovery partition, it hasnt worked for me.

    I mean that line:

    hdiutil attach RecoveryHDUpdate.dmg

    ….

    I’m sure, i’m doing something wrong…! but it says:

    hdiutil: attach failed – No existe este archivo o directorio

    (i have an spanish version of lion, but it says that the image file can’t be found..!)

    What should i do?

    Thank you

    • January 22, 2012 at 7:11 pm

      Toni,

      If you’ve downloaded the update, try moving the file from your Downloads folder to the top level of your account’s home folder. Once the file has been moved, run the command again and see if it works.

      When you open a new Terminal window, the initial directory it uses by default is the top level of your home folder.

    • mike
      March 19, 2012 at 6:54 pm

      After opening Terminal, you can use the “cd” command to move Terminal’s focus to the, for instance, Downloads folder. You could type, “cd Downloads” to move Terminal’s focus to the Downloads Directory in your Home folder. You can tell where Terminal’s focus is by the text that precedes your User name before you type any commands. Mine looks like this when I’ve typed in “cd Movies”: “MyComputer:Movies Mike$” Notice the word, “Movies” before “Mike$”? This would look like, “MyComputer:Downloads Mike$” if Terminal’s focus was in the Downloads directory. Then you run the script and Terminal can find the .dmg cause Terminal’s focus is in the Downloads directory where the actual dmg file you need to open resides, in this case the Lion Recovery Update dmg.

  11. Toni Grabulosa
    January 22, 2012 at 8:38 pm

    Oh! Thank you rtrouton! šŸ˜›

    I’ve get it with the script from dennis mueller!

    Thank you a lot! šŸ˜‰ You guys are awesome! šŸ˜‰
    Congrats! šŸ˜›

  12. Tal
    January 23, 2012 at 4:55 am

    Just wanted to say thanks, I accidentally deleted my Recovery HD partition and your post helped me out A LOT!

  13. Georgio
    January 30, 2012 at 3:16 pm

    You are the best, after months and months I found what I needed!
    Thank you VERY much!!!
    Credits go out to you, of course.
    https://discussions.apple.com/message/17443876#17443876

  14. Jokk
    February 4, 2012 at 9:55 pm

    Excellent write up! Now I can use Filevault. Many thanks.

  15. nn538
    February 20, 2012 at 11:50 am

    Thx! I had lost Recovery partition after reinstalling from TimeMachine backup, and Filevault 2 will not work without Recovery HD… I first attempted to follow this (very good) how to:

    http://www.dmitry-dulepov.com/2011/09/mac-recovery-partion-revisited.html

    But since I did not have a USB install with an existing Recovery HD, your solution with using the Apple update worked best in my case.

    Excellent how-to.

  16. Anthony
    February 27, 2012 at 1:42 am

    This really helped! OS X Mountain Lion DP1 has a broken Recovery HD for me as well. I can view it after holding Option, and/or holding Command + R, but it just goes to the Apple boot screen with the spinning gear for ages — never actually enters into the Recovery HD partition šŸ˜¦

  17. March 8, 2012 at 12:43 am

    Great information, worked a treat!

  18. RickyTang
    March 24, 2012 at 11:57 pm

    I bought an SSD and cloned my current HDD. Unfortunately, the recovery partition was now missing. This tutorial fixed my problem. Thank you very much!

  19. Bryan
    March 31, 2012 at 6:29 pm

    Used Super Duper to clone to a new drive and lost the recover partition, you saved the day. Thanks!

  20. Martin J James
    April 5, 2012 at 11:25 pm

    Hi. Get all the way through the install but final code input results in a request for a password.
    It is not,however, possible to put in any text via the keyboard?!!!

    Help…..

    Regards Martin J

    • Martin J James
      April 7, 2012 at 9:38 am

      Sorted this. Did a verify on the drive and found some minor corruptions. Used the Apple Internet recovery facility. This allowed me to repair the drive. Re-ran the code above and all worked! New recovery partition in place. Thanks for a brilliant bit of coding! Regards Martin J

  21. James W
    April 10, 2012 at 2:28 pm

    Awesome, thanks very much for this. Worked perfectly.

  22. Rob S
    April 14, 2012 at 2:50 pm

    Thanks very much – this worked great. I had installed Lion on a new SSD drive in my older MacBook which I use for work – for some reason it failed to install a recovery partition. My company is OK with using a personal Mac — but they want it encrypted – and they are beginning to use BigFix/TEM to ensure compliance. This will allow me to use FV2 and become complaint. Thanks again!

  23. Jeremy
    April 16, 2012 at 3:14 am

    This worked perfectly for me. I had a Lion partition and a BootCamp partition on my hard drive, but after creating another partition for Snow Leopard, I lost my Recovery HD. Shortly after that, my Lion partition got corrupted, and I called Apple to help. The guy helping me said I had to buy an external hard drive and back up everything using Time Machine, then reinstall everything again, so I bought a Time Capsule and did that. When I was trying to repartition my drive for Snow Leopard and BootCamp, Mac OS X deleted my recovery HD again! I did a google search and came across this page, and everything worked perfectly. I now have 5 partitions: the EFI partition, Mac OS X Lion, Recovery HD, Mac OS X Snow Leopard, and BootCamp.

  24. nate
    April 24, 2012 at 10:19 pm

    tried this on 2 seperate drives that were created with superduper,
    getting the spinning wheel of doom once i reboot and get to the login screen.
    then it crashes and forces a reboot, however the recovery partition is intact.

  25. April 30, 2012 at 4:03 am

    Note, if you see any errors before or after “Creating recovery partition: finished”, and your partition isn’t being created, you need to reboot into internet recovery mode (Command+R), and run Repair Disk in Disk Utility.

  26. MastaPCkillah
    May 22, 2012 at 8:03 pm

    GREAT WORK EVER for this process…
    Thank You very much, it helps best and saves days

  27. TetherPole
    May 24, 2012 at 10:07 pm

    Worked like a charm. THANKS! Consider updating your instructions for those who don’t understand what is meant by “the main boot partition”. Personally, since I don’t know Mac partitioning and formats I was unable to determine which disk/partition I was suppose to use in the command for merging. There are a couple small disks/partitions that could be mistaken as the boot partitions. Likely some error would occur if you tired to merge them with the erased Recovery disk/partition but it is best to be as clear as possible with these types of instructions since people may get lost or screw themselves out of their data. Even though you say to backup, people don’t. For mine there were 0-4 (Five total) disks/partitions. I have Lion installed with Bootcamp for Windows 7.
    0 (disk0) – was listed as a 251.0 GB Type”GUID_partition_scheme”
    1 (disk0s1) – was 209.7 MB Type”EFI”
    2 (disk0s2) was 124.9 GB Type”Apple_HFS” Name”Macintosh HD”
    3 (disk0s3) – was 650.0 MB Type”Apple_Boot” Name”Recovery HD”
    4 (disk0s4) – was 125.3 GB Type”Microsoft Basic Data” Name”BOOTCAMP”.
    Notice that the total size of disk/partition 2+4 equals disk/partition 0. Also, keep in mind that disk 2 & 4 which are the primary Mac OS and primary Windows Bootcamp partitions can be any size. Mine are close to equal because I split the 256 GB HDD equally in two partitions when I installed MAC OSX and Bootcamp.
    In short: choose the disk which has the type “Apple_HFS” and or name “Macintosh HD” that is large in size relative to the other partitions, when you are determining which drive/partition to use for the merge. The type or name may be different on your system but “the main boot partition” should be one of the larges ones and should be in GB not MB. Verbose, I know, but I hope this helps someone.

  28. Andy
    June 2, 2012 at 7:11 pm

    This was incredibly helpful for a system drive I copied with CarbonCopyCloner. It didn’t pull over the recovery partition, but helped me create it!

  29. June 23, 2012 at 6:01 pm

    Creating recovery partition: finished
    Error (async): File system verify or repair failed (-69845)

    after following all the steps the above error occurs. even if recovery partition says “finished” .. Recovery Hd doesnt appear when i reboot the system. plz help !

  30. June 23, 2012 at 7:35 pm

    also tried the “command+R” solution .. doing that it gives this error

    “no bootable device found. please insert the disk and press any key”

    • Abhishek Kumar
      August 28, 2012 at 11:57 am

      Abhishek Kumar :
      Did you read the following comment above?

      Jeremy M. :
      Note, if you see any errors before or after ā€œCreating recovery partition: finishedā€, and your partition isnā€™t being created, you need to reboot into internet recovery mode (Command+R), and run Repair Disk in Disk Utility.

      Sorry for the comment below, I see you did read the post. šŸ˜‰

  31. June 29, 2012 at 6:28 am

    HELP PLEASE !

    • Abhishek Kumar
      August 28, 2012 at 11:54 am

      Did you read the following comment above?

      Jeremy M. :
      Note, if you see any errors before or after ā€œCreating recovery partition: finishedā€, and your partition isnā€™t being created, you need to reboot into internet recovery mode (Command+R), and run Repair Disk in Disk Utility.

  32. sam
    July 5, 2012 at 8:36 am

    I have just purchased a macbook with 10.7.4 lion but the Recovery HD got messed up while installing windows.
    I downloaded the script and ran it and the Recovery HD partition got created but on booting with alt+R when i choose Recover HD , it is just showing a no entry or block sign and NOT booting further.
    I even tried creating a Recovery pen drive using recovery disk assistant and tried booting from it and got the same no entry/block sign.
    Can you plz help?
    Thanks

  33. sam
    July 5, 2012 at 3:24 pm

    As i have already created Recovery HD as explained above, so after this The internet recovery option is no longer working

    • July 5, 2012 at 4:52 pm

      Sam,

      If you have a Recovery HD partition, but want to boot from Internet Recovery anyway, you can boot to Internet Recovery using Command-Option-R at startup.

  34. sam
    July 5, 2012 at 6:57 pm

    Hi,
    After creating the Recovery HD partition using the above method , i can neither boot into Recovery HD nor internet Recovery. So i guess i’ll need recovery HD for 10.7.4 to make it work. But not sure how to get it.

  35. sam
    July 6, 2012 at 6:12 am

    Hi, Just found that internet Recovery mode is working , but apple support is telling me that i should also have EFI partition on my disk before proceeding with Re-installation of lion ? Is it so ? Can’t we install lion on fresh drive if the person is not having EFI partition?

  36. King amada
    July 15, 2012 at 4:15 pm

    I forcefully shutdown my MBP 2011, but after it restart and I login, it shows the apple logo. But after sometime it will change into a circle with Aline through it. And it will stock there and do nothing. Then I try to boot in safe mode by pressing shift button when starting the system but it did not work. I tried booting in apple testing mode and it did and test all my hardware and found no problem. Then I tried to boot by pressiing command plus R key. And I was able to boot to disk utility menu. Unfortunately I can see my drive but when I click it I can’ go to the first aid tab. And when I click the first disk at the up, it’s I will be able to go to first aid tab but when I click repair it’s going to come up with error: storage system verify or repair failed. Then I try to use terminal, I have used diskutil command but it doesn’t work I try to use the fsck too, it still doesn’t work. Please somebody help me. I don’t want to lose my files.

  37. July 26, 2012 at 9:30 pm

    Hmm, I came here trying to find a solution for me not being able to install Mountain Lion on my mid-2009 MacBook Pro (13″). I did everything here, and I got the “Creating recovery partition: finished” prompt, but then it’s followed by an “Error (async): unable to write a Windows boot.ini file” prompt.

    Yes, I have a BootCamp partition; now that partition is unbootable šŸ˜†

    That’s fine, BUT, the recovery partition isn’t made either. I can’t boot into it using Command+R, and when I run disktuil list, it doesn’t list the recovery partition.

    What can I do now? Thanks.

  38. August 28, 2012 at 5:34 pm

    Thanks a lot! I thought I needed two partitions on my new disk if I wanted Windows (RTFM yeah yeah), so this was a great help getting back to one big partition. I did it on Mountain Lion, and invested $39 in Carbon Copy Cloner which is able to add the Recovery HD for Mountain Lion through GUI, so the best money spend for me! Also helped me clone my old disk to the new disk, saving me a lot of time on setting up the new disk, but I couldn’t have done it without your quick step-by-step guidelines šŸ˜‰

  39. Romain Van Aelst
    September 21, 2012 at 2:47 pm

    Oh thanks heaven I stumbled on this!

    The title could as well be: “How to downgrade from 10.8 to 10.7 on Macbook Air, the fast way”.

    Tried so many different things to downgrade from 10.8 to 10.7, because there is no 32bit kernel in 10.8. After following every tip, trick, apple support thread, script, magical dance (yes, there were virgins), etc … nothing worked. I even started to think to fuckup both partitions, main and recovery, so my mac wouldn’t be able to startup and force a net recovery. Hoping that I would have the chance to choose 10.7 to download and install.

    Luckly I found your page and you Sir, saved the day.

    Thanks.

  40. September 22, 2012 at 9:40 pm

    Thanks a lot for this post and comments. This really helped me here.
    Just one comment Ā : I had problems merging ma partitions (wouldn’t work) then I realised my boot partition was journalised and I had to replace the line of code “diskutil mergePartitions HFS+ MacHD disk0s3 disk0s4″ by ” diskutil mergePartitions JHFS+ MacHD disk0s3 disk0s4″
    Cheers to you all, and thanks again!

  41. AC
    October 6, 2012 at 2:01 am

    Hi thanks for your tutorial but i dont know if i can doit if i have a macbook air mid-2011 with lion 10.7.5
    I just deleted the malfunctioning Recovery HD and the step 3 gives my this error:

    Abrahams-MacBook-Air:Downloads acoriat$ hdiutil attach RecoveryHDUpdate.dmg
    hdiutil: attach failed – No such file or directory
    Abrahams-MacBook-Air:Downloads acoriat$
    Abrahams-MacBook-Air:Downloads acoriat$ pkgutil –expand /Volumes/Mac\ OS\ X\ Lion\ Recovery\ HD\ Update/RecoveryHDUpdate.pkg /tmp/RecoveryHDUpdate
    Could not open package for expansion: /Volumes/Mac OS X Lion Recovery HD Update/RecoveryHDUpdate.pkg
    Abrahams-MacBook-Air:Downloads acoriat$
    Abrahams-MacBook-Air:Downloads acoriat$ hdiutil attach /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/RecoveryHDMeta.dmg
    expected CRC32 $6499E274
    /dev/disk1 Apple_partition_scheme
    /dev/disk1s1 Apple_partition_map
    /dev/disk1s2 Apple_Driver_ATAPI
    /dev/disk1s3 Apple_HFS /Volumes/Recovery HD Update
    Abrahams-MacBook-Air:Downloads acoriat$
    Abrahams-MacBook-Air:Downloads acoriat$ /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/Scripts/Tools/dmtest ensureRecoveryPartition / /Volumes/Recovery\ HD\ Update/BaseSystem.dmg 0 0 /Volumes/Recovery\ HD\ Update/BaseSystem.chunklist

    I dont know what else to do.
    I have searched for a solution for rebuilding the recovery hd for a long time and the only thing i found is about creating it in a flash drive or another external disk.
    Please help!!!

  42. January 26, 2013 at 6:49 am

    Excellent guide! Thanks a ton! Worked like a charm on OS X Mountain Lion 10.8.2 post installing the OS.

  43. Cesar A Briceno
    January 28, 2013 at 5:49 pm

    Very useful guide, just did it on my mac 10.7.5 (Lion), it did the job really well. Thanks a lot

  44. John
    February 12, 2013 at 3:34 pm

    How about a non booting system – I have a USB to SATA adapter, can I plug the defunct mac’s new hard drive into my RMBP and change the partition where this is set to run to, and have it prepare that externally connected drive so that it’ll let me do the internet recovery on the new drive for the non functional macbook pro?

  45. Michiel
    February 14, 2013 at 7:38 pm

    Totally works on 10.7.5. Didn’t even have to reboot for Find My Mac to recognize the recovery partition! I’ll definitely be keeping this page for later reference!

  46. nycpilot
    February 17, 2013 at 12:01 am

    Flawless even including my own paranoia. THIS is the sort of quality and TESTED work that we love to see.

  47. lazar
    July 26, 2013 at 8:24 pm

    Adaptable to Snow Leopard in any way? I can’t seem to find a downloadable .pkg for Snow Leopard.

    • July 26, 2013 at 8:26 pm

      There wasn’t a Recovery HD partition in 10.6.x. Apple started having recovery partitions with 10.7.0.

  48. Lyes
    October 28, 2013 at 6:55 am

    instructions for mavericks 10.9 please.

  49. October 29, 2013 at 8:34 pm

    Please help! This command:
    hdiutil attach /tmp/RecoveryHDUpdate/RecoveryHDUpdate.pkg/RecoveryHDMeta.dmg

    Gave me this response:
    hdiutil: attach failed – No such file or directory

    I followed every step up to here and it seemed to be working. Any ideas about what to do next?
    Thank you so much,

  50. November 9, 2013 at 5:00 am

    i would like to restore the recovery partition on my new imac late 2013 the came with moutain lion , , im on mavericks, abut i dont want to do aclean install cos i just done one in order to bootcamp assistant ta create the windows partition. so is there a solution for owners of moutain lion or mavericks ? to restore this recovery without erasing the entire HDD. thanks a lot

  51. Giovanni Mattana
    March 22, 2017 at 2:01 pm

    Hello guys,
    This morning my cappuccino fell on my Macbok Air Mid 2011 (OsX 10.7.2). I have also to say that there was a bunch of sugar in it, not sure if all dissolved.
    I tried to make things up, but no way. The recovery partition is unreadable, and the trick Cmd+R on startup does not work. The screen is black, but I can hear my MB working.
    Any suggestions?

  1. No trackbacks yet.

Leave a comment