Home > Mac administration, Mac OS X > Latest version of Skype now only available for Macs running 10.9.x or higher

Latest version of Skype now only available for Macs running 10.9.x or higher

While assisting a user today whose workstation is running 10.8.5, I downloaded the latest version of Skype and tried to run it. To my surprise, I received the following message.

Screen Shot 2014-05-22 at 4.23.18 PM

It looks like Skype 6.1.7 only supports 10.9 and higher, which is not something mentioned on the Skype support site’s system requirements page.

Screen Shot 2014-05-22 at 4.23.04 PM

The new system requirements are available on the Skype download page by clicking the System Requirements link found there.

Screen Shot 2014-05-22 at 3.32.57 PM

For those that need a version of Skype that works on 10.6.x – 10.8.x, it looks like Skype 6.1.5 (334) is the latest version available. It’s available from the following link:

http://www.skype.com/go/getskype-macosx-106-107-108

Hat tip to @tvsutton for finding the download link for the latest version of Skype that works on 10.6.x – 10.8.x.

  1. Manny
    May 30, 2014 at 2:17 pm

    This is indeed surprising, because breaking backwards compatibility is usually done for a major version with major features and benefits that aren’t available in previous platforms.
    So in this case, I wonder what new feature or capability in Skype relies on a feature in OSX 10.9 or fails because of a bug in OSX 10.8.5 and below?

  2. dggh
    August 2, 2014 at 7:32 am

    thx

  3. sonical
    August 6, 2014 at 9:18 am

    the new feature in non removable banner ads, I believe

  4. August 12, 2014 at 3:13 am

    Quit Skype
    Right click Skype
    Show Package Contents
    Open the folder named Contents
    Replace info.plist with this new one
    https://dl.dropboxusercontent.com/u/172828/Info.plist
    Tada, now you can use your old version of Skype regardless of which version you currently have

    • Saif
      September 21, 2015 at 11:34 am

      Hi Christain,

      Can you share that Info.plist if you still have it somewhere or can you let me know where can I find one.

      Thanks,

  5. Keith Scott
    August 20, 2014 at 8:27 am

    I have OSX10-4-11 on Mac G5
    How much longer will I have before having to cease my use of Skype?

  6. rich
    April 3, 2016 at 10:19 am
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: