Archive

Archive for May 22, 2014

Latest version of Skype now only available for Macs running 10.9.x or higher

May 22, 2014 8 comments

While assisting a user today whose workstation is running 10.8.5, I downloaded the latest version of Skype and tried to run it. To my surprise, I received the following message.

Screen Shot 2014-05-22 at 4.23.18 PM

It looks like Skype 6.1.7 only supports 10.9 and higher, which is not something mentioned on the Skype support site’s system requirements page.

Screen Shot 2014-05-22 at 4.23.04 PM

The new system requirements are available on the Skype download page by clicking the System Requirements link found there.

Screen Shot 2014-05-22 at 3.32.57 PM

For those that need a version of Skype that works on 10.6.x – 10.8.x, it looks like Skype 6.1.5 (334) is the latest version available. It’s available from the following link:

http://www.skype.com/go/getskype-macosx-106-107-108

Hat tip to @tvsutton for finding the download link for the latest version of Skype that works on 10.6.x – 10.8.x.

%d bloggers like this: